Personal tools

Vcsn 2.7 (March 25th, 2018)

From LRDE

Jump to: navigation, search


We are happy to announce the release of Vcsn 2.7. This is mostly a bug fix release, with improvements in the documentation, based on user feedback. Most of our efforts are currently devoted to Vcsn 3.0.

For more information, please, the NEWS file.

Documentation

Available Ports

Docker

Run this command to pull and start the Vcsn docker image on port 80
docker run -d -p 8888:80 lrde/vcsn:2.7

Debian Jessie

Run this command
echo 'deb http://www.lrde.epita.fr/repo/debian/ stable/' >/etc/apt/sources.list.d/lrde.list
apt-get update
apt-get install vcsn
# Jupyter is not currently available on Debian
apt-get install python3-pip python3-dev libzmq3-dev
pip3 install jupyter

Archlinux (AUR)

Run this command:
yaourt -S vcsn

MacPorts (Portfile)

Run this command:
sudo port sync && sudo port install vcsn
or, to upgrade vcsn if you already installed it:
sudo port sync && sudo port upgrade vcsn

Be sure to have Boost installed for Python 3.6. The safest way is to run this before:

sudo port uninstall boost && sudo port install python36 boost +python36

Downloads

  • Tarballs (sources to compile):
    • vcsn-2.7.tar.bz2 (14MiB) (SHA256: e8d3061e6fcc5612566aaa8e78019646a7d74c1bdab9161437aded08608bf988)
    • vcsn-2.7.tar.xz (14MiB) (SHA256: 95623ced01a312f60bb754ced6e9d143884e8f3063774ce6dba114147fd59618)

Requirements

In order to compile Vcsn 2.7, you need:

Boost
Boost (version 1.49 or later) provides free peer-reviewed portable C++ source libraries (at least Boost.IOStreams, Boost.Filesystem, Boost.Flyweight, Boost.Python, Boost.Regex, and probably others).
Ccache
Compiler cache.
C++ compiler
Clang 3.6 or newer and GNU G++ 4.9 or newer are known to work properly.
Doxygen
To build the C++ reference manual.
Graphviz
The display of automata is made using AT&T Graphviz library. (On Ubuntu/Debian, install the following package: graphviz)
Flex
The Flex scanner generater, 2.5.37 or better.
IPython
Although not strictly needed, it is required if you want to enjoy the Vcsn interactive notebooks.
Python
Python 3 is required
Yaml-cpp
Version 0.5.1 or 0.5.3 or more recent, but not 0.5.2.