Vcsn 2.7 (March 25th, 2018)

From LRDE

Revision as of 18:12, 25 March 2018 by Akim (talk | contribs) (Vcsn 2.7)


We are happy to announce the release of Vcsn 2.7. This is mostly a bug fix release, with improvements in the documentation, based on user feedback. Most of our efforts are currently devoted to Vcsn 3.0.

For more information, please, the NEWS file.

Documentation

Available Ports

  • Docker
Run this command to pull and start the Vcsn docker image on port 80
docker run -d -p 8888:80 lrde/vcsn:2.7
  • Debian Jessie
Run this command
echo 'deb http://www.lrde.epita.fr/repo/debian/ stable/' >/etc/apt/sources.list.d/lrde.list
apt-get update
apt-get install vcsn
# Jupyter is not currently available on Debian
apt-get install python3-pip python3-dev libzmq3-dev
pip3 install jupyter
  • Archlinux (AUR)
Run this command:
yaourt -S vcsn
Run this command:
sudo port sync && sudo port install vcsn
or, to upgrade vcsn if you already installed it:
sudo port sync && sudo port upgrade vcsn

Be sure to have Boost installed for Python 3.6. The safest way is to run this before:

sudo port uninstall boost && sudo port install python36 boost +python36

Downloads

  • Tarballs (sources to compile):
    • vcsn-2.7.tar.bz2 (14MB) (SHA256: f9f75b690304ce5c9914dde1aedf3a6135a2b7af7582ebb4a954fdffc7c79f8c)
    • vcsn-2.7.tar.xz (14MB) (SHA256: 2156d80a740a10174110d88876c11c9e3904cfd6f2fac018be5948444e4ca6b3)

Requirements

In order to compile Vcsn 2.7, you need:

Boost
Boost (version 1.49 or later) provides free peer-reviewed portable C++ source libraries (at least the Boost.Python and Boost.Regex components, and probably others).
Ccache
Compiler cache.
C++ compiler
Clang 3.6 or newer and GNU G++ 4.9 or newer are known to work properly.
Doxygen
To build the C++ reference manual.
Graphviz
The display of automata is made using AT&T Graphviz library. (On Ubuntu/Debian, install the following package: graphviz)
Flex
The Flex scanner generater, 2.5.37 or better.
IPython
Although not strictly needed, it is required if you want to enjoy the Vcsn interactive notebooks.
Python
Python 3 is required
Yaml-cpp
Version 0.5.1 or 0.5.3 or more recent, but not 0.5.2.